NOTRAL - We are having problems receiving emails – Incident details

We are having problems receiving emails

Resolved
Major outage
Started 21 days agoLasted 29 minutes

Affected

Customer Service

Major outage from 8:38 AM to 9:07 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    Due to issues we are unable to receive our emails. Customer service may be delayed. We will be back to you shortly.

    Alternatively, you can use the support form until the issue is resolved.